Trying to update to latest release.

Hi, I'm trying to update to the latest release but I keep getting many dependency requires errors when I do mix deps.get My current dependencies are:

{:membrane_core, "~> 1.0.0-rc0", override: true},
{:membrane_http_adaptive_stream_plugin, "~> 0.8.1"},
{:membrane_mp4_plugin, "~> 0.16.0"},
{:membrane_h264_ffmpeg_plugin, "~> 0.21.6"},
{:membrane_aac_plugin, "~> 0.12.1"}

But when I run the command trying to update everything I receive this error:

Resolving Hex dependencies...

Failed to use "bunch" (version 1.6.0) because
  membrane_core (version 1.0.0-rc0) requires ~> 1.6
  membrane_h264_ffmpeg_plugin (version 0.21.6) requires ~> 1.3.0

** (Mix) Hex dependency resolution failed, change the version requirements of your dependencies or unlock them (by using mix deps.update or mix deps.unlock). If you are unable to resolve the conflicts you can try overriding with {:dependency, "~> 1.0", override: true}

And when I try to update the other dependencies below the membrane_core one, every other dep complains about a required version of a different dependency. I want to try the new features but not sure how to solve this issue.

21 responses